System Requirements

Operating System:

  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows Vista
  • Microsoft Windows 7
  • Microsoft Windows 8
  • Microsoft Windows 10
  • Microsoft Windows Server 2003
  • Microsoft Windows Server 2008

Please note: the latest version cannot be installed on Windows XP, Vista without SP2, Windows Server 2003, Windows Server 2008 without SP2, Windows 7 without SP1. To use Sync2 you will need to install the previous version of Sync2.

Software:

  • Microsoft Outlook 2002 (Outlook XP)
  • Microsoft Office Outlook 2003
  • Microsoft Office Outlook 2007
  • Microsoft Office Outlook 2010
  • Microsoft Office Outlook 2013
  • Microsoft Office Outlook 2016
  • Microsoft Office Outlook 2019

Please note that product does not support Microsoft Office Outlook 2013 RT.

Environment:

  • Microsoft .NET Framework 4.5 (available with .EXE install package)
  • Visual C++ Redistributable Packages for Visual Studio 2013 (available with .EXE install package)

Hardware:

  • RAM:
    • Minimum: 768 MB
    • Recommended: 2 GB or more
  • CPU type:
    • Pentium III-compatible or higher
  • CPU speed:
    • Minimum: 500 MHz
    • Recommended: 1 GHz or higher

Will not run on Windows on ARM processor, must be desktop version of Windows and have Intel/AMD CPU, not ARM CPU, like Microsoft Surface Pro X, for example.


20 Years-in Business Anniversary! Here’s a gift for You. Get additional 20% OFF on all Sync2 products